14 Septembre 2022

Avertissement de version PHP obsolète dans WordPress : comment y remédier et qu'est-ce que cela signifie ?

WordPress nous avertit que la version de l'interpréteur PHP utilisé est obsolète et peut avoir des problèmes de sécurité, mais ce n'est pas nécessairement vrai.

Print Friendly, PDF & Email

WordPress est principalement écrit sur le langage de script PHP et est sans aucun doute l'une des parties qui ont le plus d'impact sur tous les sites WordPress existants. Les parties principales non seulement du backend mais aussi du frontend de l'interface et de la page WordPress existent grâce à PHP, ainsi que bien sûr tous les plugins et thèmes.

Il nous offre également la possibilité de faire beaucoup quand il s'agit de créer un site Web, car nous ne le trouvons pas seulement dans les modèles de page et les plugins, mais, en plus de cela, il constitue tous les fichiers qui composent le tableau de bord WordPress . . En bref, sans PHP, votre site Web n'existerait même pas. Cet article concerne la compréhension et la correction de l'avertissement de version PHP obsolète dans WordPress

Cependant, PHP n'est pas quelque chose que vous devez maîtriser pour utiliser l'application, c'est-à-dire le CMS, car les utilisateurs occasionnels peuvent gérer leurs sites Web avec plaisir sans avoir besoin de savoir comment écrire une seule ligne de HTML, PHP, JavaScript ou CSS.

Quelque chose que tous les utilisateurs de WordPress doivent savoir à propos de PHP est l'énorme effet qu'il a sur la sécurité et les performances de leurs sites Web. Ce langage de script côté serveur s'est progressivement amélioré au fil du temps et continue d'aller dans la bonne direction à chaque mise à jour consécutive. Une nouvelle version de PHP sort sur le marché presque une fois par an. Pour chaque version de branche du langage, il y a un support constant pendant deux années complètes. La troisième année ne recevrait que les mises à jour de sécurité absolument critiques ; par conséquent, votre version de PHP ne fait pas partie de ces tâches que vous pouvez configurer une fois puis oublier.

Un énorme problème auquel la communauté WordPress est confrontée est le fait que de nombreux sites, entreprises, développeurs et hébergeurs ne prennent pas en charge dernières versions du langage de script. C'est particulièrement frustrant quand on sait à quel point il est rapide et facile de le mettre à jour.

La durée de vie des anciennes versions de PHP s'épuise pour votre WordPress

Depuis le 14 septembre 2022, la dernière version de PHP est la 8.1. C'est aussi sans doute le plus grand à ce jour. Les versions 5.5, 5.6 et même 7.0 ont maintenant atteint l'état EOL (End of Life). C'est une partie standard de chaque cycle de publication de PHP. Une fois qu'une version donnée atteint son EOL, PHP abandonnerait les dispositions de support de sécurité pour celle-ci.

Si vous vous demandez : "PHP 8.0 ne vient-il pas de sortir ?!”- c'était il y a 1 an et 9 mois. Et pour être exact, PHP 8.1 n'a commencé à recevoir des mises à jour de sécurité qu'à partir de début décembre 2021. Le support actif de PHP 7.4 a été interrompu avant même la date de fin du support de sécurité de la ver. 7. De plus, le support de sécurité pour 7.4 se terminera bientôt, c'est-à-dire début décembre 2022.

Versions PHP en fin de vie

Selon la page de statistiques officielle de WordPress.org Au moment de la publication de cet article, seulement environ 56 % des utilisateurs ont déjà effectué une mise à niveau vers une version PHP prise en charge. Un très petit nombre (7 %) utilisent PHP 8, et seulement 1 % utilisent réellement la nouvelle version 8.1 du langage de script. Ce que nous pouvons voir, c'est le fait que la plupart des utilisateurs - plus de 34 % - continuent d'utiliser PHP 7.3, PHP 7.2 et 7.1. Ce qui est encore plus effrayant, c'est que la moitié des utilisateurs de WordPress utilisent des versions obsolètes et non prises en charge de PHP.

Version PHP obsolète pour WordPress

Pourquoi WordPress nécessite-t-il des versions plus récentes de PHP ?

En décembre 2018, au WordCamp US, un coup de poing très attendu dans l'exigence minimale pour la version PHP sur un site WordPress a été annoncé. Matt Mullenweg a suggéré lors de son State of the Word 2019 que 5.6 était la version minimale jusqu'à la mi-2019 et qu'elle serait à nouveau mise à niveau vers PHP 7.0 au cours du second semestre. Tout cela sera un fait au cas où tout se passerait bien. Cette affirmation a été extrêmement applaudie - elle a reçu beaucoup plus d'éloges que les précédents reportages de Gutenberg.

Cependant, le annonce par l'équipe WordPress ce fut une grande surprise pour toute la communauté WordPress. Bien sûr, continuer avec les dernières versions de PHP est une bonne nouvelle, même si la version minimale de PHP requise pour faire fonctionner un site basé sur WordPress n'a pas été touchée depuis des années. Tous ces changements étaient attendus depuis longtemps et sont ensuite devenus des normes de facto.

La WordPress Core Team est responsable de la gestion des CMS les plus utilisés au monde. Cela dit, ils se sont engagés à faire en sorte que WordPress suive le rythme de PHP au cours des prochaines années et s'efforcent de sensibiliser, tout en changeant l'apathie, la prise de conscience ou la prise en charge des nouvelles versions de PHP.

"L'objectif immédiat est de mettre en place la structure de soutien et l'éducation/les ressources du propriétaire du site, etc. Afin de pouvoir réduire plus activement le nombre de sites WordPress actifs existant sur les versions précédentes de PHP EOL et ainsi améliorer la sécurité et les performances du web ».

Le plan actuel prévoit l'affichage d'un avertissement dans le panneau d'administration back-end pour les sites utilisant des versions de PHP antérieures à la branche PHP prise en charge (dans ce cas, par exemple, antérieures à 7.4). Le message « avertissement » contiendrait un lien vers l'une des pages de support de WordPress qui explique brièvement le problème, suivi d'une plongée dans la façon dont tous les propriétaires de sites peuvent être prêts pour une mise à niveau vers la version PHP sous-jacente de leur serveur, puis l'exécuter.

Wordpress Avertissement version PHP

Ces alertes ont commencé à apparaître sous forme de messages de notification à partir de WordPress 5.1, qui a été publié il y a quelque temps vers mars 2019.

Les sites qui choisissent de rester sur PHP 7.3 ou une version antérieure pourront toujours recevoir des mises à jour de sécurité et peut-être quelques corrections de bogues, mais n'auront pas la possibilité d'utiliser la version la plus récente et la plus importante de WordPress tant qu'ils n'auront pas suivi le processus de mise à jour de leur propre site. .PHP.

Avant la sortie très attendue de WordPress 6.0, il a été déclaré que le CMS visait à prendre pleinement en charge la version 8 de PHP dans sa version. Actuellement, la page officielle des exigences suggère que pour exécuter WordPress, votre hébergeur doit prendre en charge la version 7.4 ou ultérieure.

Cependant, il y a la note officielle qui stipule:

Même si WordPress Core continue d'étendre sa prise en charge des nouvelles versions de PHP, il n'est pas prévu de supprimer la prise en charge des anciennes versions jusqu'à ce que les chiffres d'utilisation montrent que l'impact sur les utilisateurs sera minime.

L'histoire derrière la fonctionnalité d'avertissement d'avertissement de version PHP obsolète.

Tout cela découle des statistiques de mise à jour compilées quelques jours après que la version 5.0 de WordPress ait signalé qu'environ 85 % des utilisateurs géraient déjà leurs sites Web avec PHP 5.6 ou une version ultérieure. Cela montre qu'une petite partie de la communauté active prend note de ces avertissements en général.

L'équipe principale de WordPress a eu des commentaires sur des notifications spécifiques dans le but d'encourager les utilisateurs du monde entier à mettre à jour leurs versions PHP et ces notifications se sont avérées extrêmement efficaces. Avec la sortie de Yoast SEO 4.5 au début de 2017, leur équipe a expérimenté l'utilisation d'un approche d'alerte similaire . Yoast a ajouté un avis exhortant les propriétaires de sites avec des versions PHP obsolètes à le mettre à jour. La seule façon de désactiver cet avertissement était de procéder à la mise à jour. Les résultats ont montré que les mises à jour avaient un taux deux fois plus élevé qu'avant l'apparition de la notification.

Nous avons vu que cet avis avait un impact important et nous avons maintenant moins de la moitié des utilisateurs de PHP 5.2 qui ont le noyau WP. Aussi ennuyeux soit-il, cela fonctionne. C'est pourquoi je ne parierais pas que l'équipe de base fait autre chose que ce que nous faisons.

- Joost de Valk, fondateur et CPO de Yoast

Cette initiative a été appelée le projet Yoast WHIP et démontre que la "nuisance" (comme l'appelle de Valk, dans le ticket Trac original qu'ils ont écrit sur la fusion de WHIP dans le noyau WordPress) pour mettre à niveau les utilisateurs pourrait en fait conduire à un changement qui rend tout mieux pour tout le monde.

À la suite du projet WHIP, ainsi que de l'augmentation positive du nombre de mises à jour PHP, le Servez un projet heureux.

Pourquoi ne pouvez-vous pas utiliser une ancienne version de PHP pour toujours ?

L'une des raisons les plus importantes pour mettre à jour votre version de PHP est La sécurité. Votre WordPress sera beaucoup plus sécurisé s'il exécute l'une des dernières versions du langage de script. Il garantira que votre entreprise est protégée des vulnérabilités les plus actuelles du "marché" et sera également régulièrement corrigée pour les failles de sécurité, ainsi que des améliorations majeures en termes de vitesse d'exécution et de performances.

référence php

Parmi les différentes raisons de préférer une version mise à jour :

  • PHP 8 a déjà démontré capacité de traitement et de charge de données beaucoup plus élevée par rapport à ses prédécesseurs. En plus des performances élevées, vous vous attendez probablement à d'énormes économies de mémoire. La raison en est qu'une optimisation substantielle a été faite dans les structures de données internes.
  • Les benchmarks PHP officiels nous montrent que PHP 8 permet au système d'effectuer deux fois plus de requêtes par seconde par rapport à PHP 5.6 et jusqu'à 50% par rapport à 7.4 avec presque la moitié de la latence.
  • D'un point de vue commercial, PHP 8 offre des avantages indéniables par rapport à ses prédécesseurs, tels que excellentes performances, résilience et utilisation. Il est capable de profiter d'un avantage modeste en ce qui concerne WP.
  • Les entreprises, comme certains géants du e-commerce, avec une forte présence en ligne ils trouveraient PHP 8 particulièrement adapté à leur site Web.
  • Les exigences minimales pour WordPress ont augmenté.
  • En fin de compte, les utilisateurs auront des problèmes de compatibilité avec des plugins et des scripts incompatibles installés avec leur version obsolète.
  • Enfin et surtout, probablement le la meilleure pratique consiste à approuver une version stable. Toutes les nouvelles fonctionnalités favorisent la mise à niveau.

Comment mettre à jour PHP en toute sécurité

Nous espérons maintenant vous avoir convaincu que la mise à jour de votre version de PHP est absolument nécessaire si vous voulez les meilleures performances et une sécurité maximale de votre site Web. La migration n'est pas si compliquée tant que vous procédez en toute sécurité, afin de vous assurer que la mise à jour ne casse aucun des éléments de votre site.

Chaque fois que nous envisageons de passer à une nouvelle version, la chose qui est prise en considération est la compatibilité. Notez que PHP 7 n'est pas compatible avec les versions précédentes. La principale chose à garder à l'esprit est le fait que si vous n'avez pas fait preuve de diligence dans la maintenance de votre logiciel WordPress, certains scripts, plugins ou thèmes peuvent ne pas être compatibles avec les versions spécifiques de PHP que vous souhaitez utiliser. De plus, ils peuvent ne pas fonctionner comme prévu. De plus, une mauvaise version de PHP pourrait endommager votre site en tout ou en partie. Bien sûr, il est possible que le code du plugin ou du thème soit complètement dépendant de la version précédente. En fin de compte, nous pouvons toujours essayer la mise à niveau et la rétrogradation en cas de problème.

Étape 1 : Restez calme et créez toujours des sauvegardes avant la mise à jour

Très probablement, lorsque nous mettons à jour PHP, tout se passe bien. Cependant, il n'y a jamais aucune garantie que tout se passera selon notre plan de match. En cas de problème, nous voulons et devons avoir une sauvegarde et réassembler le site Web. Tout cela est beaucoup plus facile si vous disposez déjà d'une sauvegarde propre et brillante de votre site.

La sauvegarde régulière de votre site Web est déjà quelque chose que nous faisons gratuitement, en plus de nos services. Cependant, nous vous recommandons d'avoir une nouvelle sauvegarde de votre site à portée de main, afin que vous puissiez facilement annuler vos modifications en cas de problème, même légèrement.

Nous encourageons tout le monde à générer manuellement une sauvegarde avant d'appuyer sur la gâchette et de mettre à jour leurs sites Web en direct.

Étape 2 : Créer une copie de staging locale de votre site Web

C'est toujours la meilleure idée de tester la dernière version de PHP dans un environnement de test ou de développement plutôt que sur votre site en ligne. Ce site Web intermédiaire agira comme une copie de votre site Web en direct existant, placé dans un sous-dossier du répertoire racine. Gardez simplement à l'esprit qu'une fois que vous avez créé un site de développement comme celui-ci, il définira automatiquement cette copie pour qu'elle soit la même version PHP que votre site en ligne.

Ensuite, vous devez modifier la version PHP souhaitée par répertoire. Vous pouvez facilement y parvenir en configurant des règles personnalisées pour chaque dossier.

Vous pouvez ensuite lancer des tests sur le site de développement pour évaluer la compatibilité de vos thèmes et plugins actuels et découvrir comment il réagit. Assurez-vous de vérifier le journal des erreurs pour toute erreur. Si rien d'inhabituel ne se produit, vous pouvez procéder ultérieurement à la mise à jour de votre site en ligne.

Étape 3 : Tout mettre à jour

Avant de commencer, nous devons nous assurer que vos plugins et tout le reste sont à jour. De cette façon, nous vérifierions la compatibilité avec les dernières versions de tout, obtenant ainsi les meilleures chances de succès de notre mission.

De cette façon, vous n'avez plus à vous déplacer pour réparer les choses. Assurez-vous de cliquer sur le bouton "Mettre à jour" partout où cela est nécessaire.

  • Mettre à jour WordPress lui-même
  • Mettez à jour votre thème
  • Mettre à jour tous les plugins

Étape 4 : Vérifiez la compatibilité

Vient maintenant la partie où vous vérifiez les erreurs de votre part. Les choses que vous recherchez et ce que vous pouvez trouver peuvent varier considérablement. Tout dépend de la configuration unique que vous avez. Cependant, voici notre recommandation pour l'ordre dans lequel vous testez :

  • Parcourez chaque page du site et recherchez les éléments qui ont soudainement cessé de fonctionner.
  • Vérifiez tous les plugins un par un et voyez s'ils fonctionnent comme ils le devraient.
  • Testez les fonctionnalités qui incluent vos thèmes actifs. Assurez-vous que tout fonctionne toujours correctement.
  • Allez aussi sur wp-config.phpfichier : définissez la variable WP_DEBUGcomment true. Il afficherait toutes les erreurs et tous les avertissements.
    define('WP_DEBUG', vrai);

Étape 5 : Mettez à jour votre site en ligne

Une fois la phase de test terminée, suivez les étapes pour procéder à la mise à jour.

Vers quelle version dois-je mettre à jour ?

Nous ne saurions trop insister sur le fait que la mise à jour vers la dernière version de PHP est fortement recommandée si le logiciel de votre site peut le faire sans problème. La dernière version doit être prise en charge le plus longtemps et est également celle qui contient le plus de correctifs qui améliorent les performances globales d'un site Web.

Et si quelque chose ne fonctionne pas après la mise à jour, que dois-je faire ?

Nous entrons ici dans un domaine complexe dans lequel nous allons faire quelques considérations techniques sur ce que nous avons écrit jusqu'à présent, qui est essentiellement ce que raconte la communauté internationale, composée de développeurs qui n'ont peut-être pas eu grand-chose à voir avec l'ingénierie des systèmes. .

Tout d'abord, ce qui précède est valable, c'est-à-dire que lorsque vous pouvez mettre à jour l'interpréteur PHP, vous devez mettre à jour l'interpréteur PHP, il n'y a pas de raisons telles que la paresse et la procrastination indéfinie.

Cependant, il n'est pas toujours possible de mettre à jour l'interpréteur PHP vers la dernière version pour des raisons de compatibilité, de fonctions obsolètes, de plugins qui ne sont plus supportés, divers et autres.

Nous avons des clients qui fonctionnent toujours sur PHP 5.3, des versions personnalisées au niveau du noyau de WordPress 3.5, des trucs de science-fiction pour être clair qui fonctionnent néanmoins bien, rapportent des profits et des profits et ne peuvent être mis à jour qu'avec un travail exténuant et un investissement de dizaines de milliers. d'euros.

Dans ce cas, le conseil est toujours de mettre à jour vers la version évolutive la plus récente.

Avons-nous PHP en cours d'exécution sur la version 5.2 ou 5.3 ? Nous ne pouvons pas l'amener à 8, nous ne pouvons pas l'amener à 7, mais essayons au moins de l'amener à la dernière version de la branche 5, ou 5.6 et si tout fonctionne, laissez-le fonctionner avec cette version, en attendant nous essayons de corriger les problèmes de code pour passer à une version récente, éventuellement la plus récente.

Dans ces situations, l'attention doit nécessairement être portée sur des aspects tels que la sécurité, la sauvegarde et la reprise après sinistre.

 

Vous avez des doutes ? Vous ne savez pas par où commencer ? Contactez-nous


Nous avons toutes les réponses à vos questions pour vous aider à faire le bon choix.

Discute avec nous

Discutez directement avec notre support avant-vente.

0256569681

Contactez-nous par téléphone pendant les heures de bureau 9h30 - 19h30

Contactez-nous en ligne

Ouvrez une demande directement dans l'espace contact.

INFORMATIONS

ManagedServer.it est le premier fournisseur italien de solutions d'hébergement hautes performances. Notre modèle d'abonnement est abordable et prévisible, afin que les clients puissent accéder à nos technologies d'hébergement fiables, à nos serveurs dédiés et au cloud. ManagedServer.it offre également d'excellents services d'assistance et de conseil sur l'hébergement des principaux CMS Open Source tels que WordPress, WooCommerce, Drupal, Prestashop, Magento.

JUSTE UN MOMENT !

Souhaitez-vous voir comment votre WooCommerce fonctionne sur nos systèmes sans avoir à migrer quoi que ce soit ? 

Entrez l'adresse de votre site WooCommerce et vous obtiendrez une démonstration navigable, sans avoir à faire absolument quoi que ce soit et entièrement gratuite.

Non merci, mes clients préfèrent le site lent.
haut